jOpenSimWorld

Grid Status: Online
Total Regions: 23
Visitors (30 Days): 22
Total Residents: 474
Online Now: 0
Hypergriders online: 0

Creating Events

1 year 11 months ago #3734 by SonjaGalileo
This is a bit of a "dumb" question.

I have the module installed; I see the events page but there are no buttons or links to create an event. Am I missing something, does there need to be a permission set or something?

Please Log in or Create an account to join the conversation.

1 year 11 months ago #3737 by foto50
Hi SonjaGalileo

The events module is only for displaying upcoming events ... on the website, but even more useful for the loginscreen of the viewer.

For creating events you can provide your users with a special menu item that can be created in backend with:

Menues -> New Item -> Menu Item Type -> jOpenSim -> Submit new event

Mind that jOpenSim must have jOpenSimSearch enabled for this, since this is the only possibility for the component to find out what parcels can be available for the user to create an event (depending on your global settings) ... and because of this, obviously the menu item should be accessible only for registered users ;)

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

1 year 11 months ago #3738 by SonjaGalileo
Ok, this brings up another question.

How do I enable jOpensim Search? I'm not seeing it under modules or plugins.

Please Log in or Create an account to join the conversation.

1 year 11 months ago #3739 by SonjaGalileo
Ok, I see that there is a search function under jOpensim.

I read in another post about putting the dll files in "each simulator bin" I have them in Opensim/bin. Do I also need to put them inside each region's folder too?

Please Log in or Create an account to join the conversation.

1 year 11 months ago #3740 by foto50
No, only in the ./bin folder of your simulator(s) where you execute OpenSim.exe

In other words, if you have several simulators using the same exe but with different ini files, only that one folder needs to contain jOpenSimSearch.dll to be found ... makes it easier for future updates ;)

The rest of required ini settings you find in your jOpenSim backend under "Addon -> Search"

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

1 year 11 months ago #3741 by SonjaGalileo
The dll files are in the right spot, I made the ini file changes a while back when I installed.

I have the search menu and there seems to be some data collected.



Though when II go to create an event I get an "Error: no valid land found"

www.moonlightestates.me/forum_images/Scr...2-03-20%20150617.png

I am a landowner and I have "Create Event" rights in the group. In fact, I'm the owner of the group.
Attachments:

Please Log in or Create an account to join the conversation.

1 year 11 months ago #3744 by foto50
Ok, the embedded image isnt loading for me, but the attached one with search data makes me a little amazed: 16 simulators with 71 regions, but only 1 parcel? Do they all share the same parcel? ;)

Can it be that in your opensim.ini(s) for section [DataSnapshot] the entry
data_exposure = all
is missing or has a different value?

Please Log in or Create an account to join the conversation.

1 year 11 months ago #3751 by SonjaGalileo
Just a quick clarification, what OpenSim.ini files are supposed to be active?

I have OpenSimDefaults.ini and a OpenSim.ini

Right now, each region is just one big parcel. My wife is working on splitting the regions as needed by use and content. With so many regions that can be quite a task.

If I am looking at the table correctly it shows parcels that are subdivided, named and listed in "show places". So only have a few parcels in the list coincides with the progress my Wife has made in creating individual parcels.

I can test this on another region and see if there is a change.

Please Log in or Create an account to join the conversation.

1 year 10 months ago #3753 by foto50
OpenSimDefaults.ini should never be touched. This file contains all default values and would get overwritten when upgrading OpenSim one day.

Depending on your architecture settings in
[Architecture]
Include-Architecture = "...???"
there are several other files to be focused. They are usually located in the folder ./config-include/

Basically every region has minimum 1 parcel ... so 71 regions should AT LEAST produce 71 parcels in the search database.

But if in the ini settings you have e.g.
[DataSnapshot]
data_exposure = minimum
or even commented out (then minimum is the value coming from defaults), then parcels will not be reported to jOpenSim for this required table and therefor the parcels will not turn up as valid parcels for creating events at all.

Please Log in or Create an account to join the conversation.

1 year 10 months ago #3756 by SonjaGalileo
I am showing parcels in the search summary and I'm seeing regions. I am seeing ALL of my regions, but I only see parcels that I have checked "Show Place in Search".

Sooo, by this behavior I would say it is working as expected. Unless I'm supposed to 70+ parcels rather than regions.

I believe this is just a mix up in terminology, regions vs parcels.
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.193 seconds

Search

Donate jOpenSim

Please consider supporting our efforts.

Amount

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
BareBad… 997 997
Bohemas 996 998
BoraBor… 1002 999
Crystal… 1001 1000
DeepTho… 1005 998
FoToSan… 999 995
jCity 1001 997
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
LindaKe… 1000 997
LittleC… 996 997
MonteSc… 1001 1001
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
Tartola 997 998
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

jOpenSimWorld

Grid Status: Online
Total Regions: 23
Visitors (30 Days): 22
Total Residents: 474
Online Now: 0
Hypergriders online: 0