GridMap

8 years 6 months ago #1490 by Dondray
habe die .dll neu geladen und ein gebaut. beim starten zeigt er immernoch den Fehler

[SEARCH]: starting initDataUpdate for xx.xx.xx.xx:9000/ width 1200
an. Obwohl ich port 9000 garnicht nutze.

Please Log in to join the conversation.

8 years 6 months ago #1491 by Dondray
sobald ich im viewer auf suche klicke passiert in der Console:

19:18:11 - [LLUDPSERVER]: Client packet handler for Dondray Caiben for packet MapItemRequest threw System.NullReferenceException: Object reference not set to an instance of an object
at OpenSimSearch.Modules.OpenSearch.OpenSearchModule.HandleMapItemRequest (IClientAPI remoteClient, UInt32 flags, UInt32 EstateID, Boolean godlike, UInt32 itemtype, UInt64 regionhandle) [0x00000] in <filename unknown>:0
at (wrapper delegate-invoke) OpenSim.Framework.MapItemRequest:invoke_void__this___IClientAPI_uint_uint_bool_uint_ulong (OpenSim.Framework.IClientAPI,uint,uint,bool,uint,ulong)
at (wrapper delegate-invoke) OpenSim.Framework.MapItemRequest:invoke_void__this___IClientAPI_uint_uint_bool_uint_ulong (OpenSim.Framework.IClientAPI,uint,uint,bool,uint,ulong)
at (wrapper delegate-invoke) OpenSim.Framework.MapItemRequest:invoke_void__this___IClientAPI_uint_uint_bool_uint_ulong (OpenSim.Framework.IClientAPI,uint,uint,bool,uint,ulong)
at OpenSim.Region.ClientStack.LindenUDP.LLClientView.HandleMapItemRequest (IClientAPI sender, OpenMetaverse.Packets.Packet Pack) [0x00000] in <filename unknown>:0
at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessPacketMethod (OpenMetaverse.Packets.Packet packet) [0x00000] in <filename unknown>:0
at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessInPacket (OpenMetaverse.Packets.Packet packet) [0x00000] in <filename unknown>:0
at OpenSim.Region.ClientStack.LindenUDP.LLUDPServer.ProcessInPacket (OpenSim.Region.ClientStack.LindenUDP.IncomingPacket incomingPacket) [0x00000] in <filename unknown>:0
19:18:12 - [LLUDPSERVER]: Client packet handler for Dondray Caiben for packet MapItemRequest threw System.NullReferenceException: Object reference not set to an instance of an object
at OpenSimSearch.Modules.OpenSearch.OpenSearchModule.HandleMapItemRequest (IClientAPI remoteClient, UInt32 flags, UInt32 EstateID, Boolean godlike, UInt32 itemtype, UInt64 regionhandle) [0x00000] in <filename unknown>:0
at (wrapper delegate-invoke) OpenSim.Framework.MapItemRequest:invoke_void__this___IClientAPI_uint_uint_bool_uint_ulong (OpenSim.Framework.IClientAPI,uint,uint,bool,uint,ulong)
at (wrapper delegate-invoke) OpenSim.Framework.MapItemRequest:invoke_void__this___IClientAPI_uint_uint_bool_uint_ulong (OpenSim.Framework.IClientAPI,uint,uint,bool,uint,ulong)
at (wrapper delegate-invoke) OpenSim.Framework.MapItemRequest:invoke_void__this___IClientAPI_uint_uint_bool_uint_ulong (OpenSim.Framework.IClientAPI,uint,uint,bool,uint,ulong)
at OpenSim.Region.ClientStack.LindenUDP.LLClientView.HandleMapItemRequest (IClientAPI sender, OpenMetaverse.Packets.Packet Pack) [0x00000] in <filename unknown>:0
at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessPacketMethod (OpenMetaverse.Packets.Packet packet) [0x00000] in <filename unknown>:0
at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessInPacket (OpenMetaverse.Packets.Packet packet) [0x00000] in <filename unknown>:0
at OpenSim.Region.ClientStack.LindenUDP.LLUDPServer.ProcessInPacket (OpenSim.Region.ClientStack.LindenUDP.IncomingPacket incomingPacket) [0x00000] in <filename unknown>:0
19:18:12 - [LLUDPSERVER]: Client packet handler for Dondray Caiben for packet MapItemRequest threw System.NullReferenceException: Object reference not set to an instance of an object
at OpenSimSearch.Modules.OpenSearch.OpenSearchModule.HandleMapItemRequest (IClientAPI remoteClient, UInt32 flags, UInt32 EstateID, Boolean godlike, UInt32 itemtype, UInt64 regionhandle) [0x00000] in <filename unknown>:0
at (wrapper delegate-invoke) OpenSim.Framework.MapItemRequest:invoke_void__this___IClientAPI_uint_uint_bool_uint_ulong (OpenSim.Framework.IClientAPI,uint,uint,bool,uint,ulong)
at (wrapper delegate-invoke) OpenSim.Framework.MapItemRequest:invoke_void__this___IClientAPI_uint_uint_bool_uint_ulong (OpenSim.Framework.IClientAPI,uint,uint,bool,uint,ulong)
at (wrapper delegate-invoke) OpenSim.Framework.MapItemRequest:invoke_void__this___IClientAPI_uint_uint_bool_uint_ulong (OpenSim.Framework.IClientAPI,uint,uint,bool,uint,ulong)
at OpenSim.Region.ClientStack.LindenUDP.LLClientView.HandleMapItemRequest (IClientAPI sender, OpenMetaverse.Packets.Packet Pack) [0x00000] in <filename unknown>:0
at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessPacketMethod (OpenMetaverse.Packets.Packet packet) [0x00000] in <filename unknown>:0
at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessInPacket (OpenMetaverse.Packets.Packet packet) [0x00000] in <filename unknown>:0
at OpenSim.Region.ClientStack.LindenUDP.LLUDPServer.ProcessInPacket (OpenSim.Region.ClientStack.LindenUDP.IncomingPacket incomingPacket) [0x00000] in <filename unknown>:0

Please Log in to join the conversation.

8 years 6 months ago #1492 by DJ Devil
der port 9000 der da gesucht wird ist von einer region und ist sowohl der udp als auch der tcp port von OpenSimulator die ersterstellte Region lauft auf port 9000 fuer eingehende verbindungen es sei denn du hast die standard einstellung nicht uebernommen, desweiteren hoert OpenSim.exe auf port 9000 wenn dies nicht per OpenSim.ini geaendert wurde, selbst im gridmode aendert sich der port nicht er laesst nur halt keine Logins mehr zu da diese nun vom Robust.exe bearbeitet werden, hoffe das hilft dir etwas weiter

Please Log in to join the conversation.

8 years 6 months ago #1497 by Dondray

DJ Devil wrote: der port 9000 der da gesucht wird ist von einer region und ist sowohl der udp als auch der tcp port von OpenSimulator die ersterstellte Region lauft auf port 9000 fuer eingehende verbindungen es sei denn du hast die standard einstellung nicht uebernommen, desweiteren hoert OpenSim.exe auf port 9000 wenn dies nicht per OpenSim.ini geaendert wurde, selbst im gridmode aendert sich der port nicht er laesst nur halt keine Logins mehr zu da diese nun vom Robust.exe bearbeitet werden, hoffe das hilft dir etwas weiter


Von der Start region habe ich den port geändert. in der Robust.ini sind auch andere Ports drin. Sehe gerade das in der OpenSim.ini http_listener_port = port 9000 noch drin stand. Welcher Port muss dort den rein. Wenn ich den von der Robust.ini nehme startet der Server nicht.

Please Log in to join the conversation.

8 years 6 months ago - 8 years 6 months ago #1498 by DJ Devil
im grunde genommen macht es keinen unterschied ob du 9000 oder einen anderen findest nd die meldung [SEARCH]: starting initDataUpdate for xx.xx.xx.xx:9000/ width 1200 sagt ja im grunde nur aus das das search modul die dinge die in der search gelistet werden updated also im grunde genommen kein error

PS
das er opensim mit dem port von der robust nicht startet ist ja logich da der robust den port bereits belegt

Please Log in to join the conversation.

8 years 6 months ago #1499 by Dondray

DJ Devil wrote: im grunde genommen macht es keinen unterschied ob du 9000 oder einen anderen findest nd die meldung [SEARCH]: starting initDataUpdate for xx.xx.xx.xx:9000/ width 1200 sagt ja im grunde nur aus das das search modul die dinge die in der search gelistet werden updated also im grunde genommen kein error

PS
das er opensim mit dem port von der robust nicht startet ist ja logich da der robust den port bereits belegt


Ok. aber wieso ist dieser eintrag dann rot beim starten. Dachte immer Rot währe ein Fehler.

Aber müsste in der Datenbank tabelle tabelle_opensim_search_classifieds nicht was eingetragen sein und in den anderen tabelle_opensim_search_xxxx

Please Log in to join the conversation.

8 years 6 months ago #1500 by DJ Devil
rot ist der weil ich denke das foto vergessen hat das im debug zu aendern nd da findest du nur was wenn du auch was in die suche eintraegst

Please Log in to join the conversation.

8 years 6 months ago #1501 by Dondray

DJ Devil wrote: rot ist der weil ich denke das foto vergessen hat das im debug zu aendern nd da findest du nur was wenn du auch was in die suche eintraegst



zeig er die sims nicht an wenn man eingestellt hat in der suche anzeigen? oder funktioniert es anders?

Please Log in to join the conversation.

8 years 6 months ago #1502 by DJ Devil
muesste eigentlich bin mir da jetzt aber selbst nicht sicher

Please Log in to join the conversation.

8 years 6 months ago #1503 by Dondray

DJ Devil wrote: muesste eigentlich bin mir da jetzt aber selbst nicht sicher


weil keine sim wird in der suche angezeigt

Please Log in to join the conversation.

Time to create page: 0.157 seconds

Search

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
Bay Sho… 997 1003
BoraBor… 1002 999
Canary … 997 999
Crystal… 1001 1000
DeepTho… 1005 998
FoToSan… 996 995
jCity 1001 997
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
LindaKe… 1000 997
MonteSc… 1001 1001
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

Donate jOpenSim

Please consider supporting our efforts.

Amount