jOpenSimWorld

Grid Status: Online
Total Regions: 23
Visitors (30 Days): 13
Total Residents: 454
Online Now: 0
Hypergriders online: 0

Now jOpensim search does not work.

4 months 2 weeks ago #3748 by SonjaGalileo
As I had mention in the mewe chat (and promptly got chastised for it) I am having problems with jOpensim search.

I FINALLY got the program to stop deleting the dll files. (Changed the to ReadOnly) but now I get the following error in the region simulators.:
11:41:08 - [jOpenSimSearch]: (1) Unable to connect to Search Server http://www.moonlightestates.me:80/jOpensim/index.php?option=com_opensim&view=interface.  Exception System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
   at System.Net.HttpWebRequest.GetResponse()
   at Nwc.XmlRpc.XmlRpcRequest.Send(String url, Int32 timeout, RemoteCertificateValidationCallback certCallBack)
   at jOpenSim.Search.jOpenSimSearch.GenericXMLRPCRequest(Hashtable ReqParams, String method)

This is what I have in OpensimDefaults.ini, Robust.HG.ini AND Robust.HG.ini.proto
SearchURL = "${Const|jOpensimURL}/index.php?option=com_opensim&view=inworldsearch&task=viewersearch&tmpl=component&"

I also have index_sims=true and data_exposure=all set.

At some point it did SOMETHING because I can see some stuff "indexed on the admin page



All 12 simulators are there, but I have about 70 regions, not 37.

UPDATE

As I was writing this, I see that it now showed 53 regions!

[img ]https://www.moonlighhttps://www.moonlightestates.me/search_screenie_2.pngtestates.me/search_screenie.png

THEN, after I stepped away, I see this:
12:42:11 - [XMLRPC-GROUPS-CONNECTOR]: An error has occured while attempting to access the XmlRpcGroups server method groups.getGroup at http://www.moonlightestates.me:80/jOpensim/index.php?option=com_opensim&view=interface: The remote server returned an error: (500) Internal Server Error.


I have NO idea what is going on. EVERY time I try to put in the correct URL in ANY of the ini files it just gets overwritten with the garbage URL.

I mean, adding :80 to the URL?? That hasn't been done since the early 90's and on AOL for crying out loud.

YES, I am TOTALLY frustrated. Let's not even get into the Gloebit bug!

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago #3749 by SonjaGalileo
Ya know, it is amazing what comes to mind when you wander away from the server and go vent a bit to your lovely AND understanding Wife.

When I came back in I decided to double check the PHP settings in IIS. Yes I disabled Apache and runn jOpensim through an IIS site mapped through to the DremGrid Apache httpdoc directory. THAT led me to see where I was mapping PHP.

YUP, it was mapped to the IIS installed PHP, NOT the PHP directory in DreamGrid.

Did a quick shutdown and loaded up the regions. No errors in the console so far.

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago #3750 by SonjaGalileo
Still having an issue. When viewing an avatar profile, I get this in the console:

15:06:03 - [LLCLIENTVIEW]: Exception when handling generic message Object reference not set to an instance of an object.   at jOpenSim.Profile.jOpenProfile.OpenProfileModule.HandleAvatarClassifiedsRequest(Object sender, String method, List`1 args)
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.HandleGenericMessage(Packet pack)
15:06:04 - [LLCLIENTVIEW]: Caught exception while processing OpenMetaverse.Packets.AvatarPropertiesRequestPacket for Sonja Galileo  System.NullReferenceException: Object reference not set to an instance of an object.
   at jOpenSim.Profile.jOpenProfile.OpenProfileModule.GetProfileData(UUID userID)
   at jOpenSim.Profile.jOpenProfile.OpenProfileModule.RequestAvatarProperties(IClientAPI remoteClient, UUID avatarID)
   at OpenSim.Framework.RequestAvatarProperties.Invoke(IClientAPI remoteClient, UUID avatarID)
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.HandleAvatarPropertiesRequest(Packet Pack)
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.<>c__DisplayClass822_0.<ProcessPacketMethod>b__0()

In past experiences that error usually means there is an error in the db table. Usually, a NULL value or something that is there but wasn't what was requested.

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago #3752 by SonjaGalileo
Now I have profiles working, sort of.

In the viewer I can enter what I want. BUT when I try to use the website, I get a 404 error.

HOWEVER, when I just enter random characters (used 255, 500 and even 2500 chars) It works fine.

BUT If I try to enter good ol' plain English....NO WAY JOSE!

Hers is what worked:
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


And here is what gave me the 404.
About me, well, I joined the virtual worlds in Second Life back in April of 2003. Spent a lot of time chatting, dancing and just hanging out for the first couple of years.

Then came along Mesh! I've been doing 3D modeling starting with Microsoft Flight Simulator 2002, so I knew my way around 3DS Max. I was finally able to create things in SL. I was no pro at prim building. Honestly, I sucked at it. But give me a good 3D program and I'm in business!

SL got to be a bit clickish and drama ridden so I followed my lovely wife over to InWorldz where we really let the mesh uploads fly. We built quite a collection.

I got turned onto the server side of things when I came across the Halcyon source code. At first it boggled me, and I had a few false starts over the span of a year or so. Then one day I muscled through it and got everything running. Thanks to the MOSES group and their notes.

I did some bug busting, and grid testing with the InWorldz folks that were working on Halcyon while I started up my own grid project. Part of the project contained the website side of things. I tried to develop a site from scratch. Let me tell ya it was slow going. Not being a coder by nature it was pretty much hunt and peck. Then I ran into Vinhold Starbrook and his wonderful MyWorld source code. We collaborated quite a bit on the pages, bug busting, feature suggestions and other such wrangling.

I had to take a break for a while due to some life events. After things settled down, I was looking for a project or something to get into. I came across the DreamGrid install for OpenSim. Nikki and I have always talked about transitioning to OS because of the stalled development in Halcyon at its few major bugs.

DreamGrid packaged a nice interface to OS, a Joomla based management website and there are all the FREE resources out there from sites like Outworldz and Zoomtada. Not to mention all the stuff you can get on the HyperGrid.

And HyperGrid! That means people can visit us without even having a Moonlight account!!  COOL!

And this is with EITHER text box!

Please Log in or Create an account to join the conversation.

4 months 1 week ago #3754 by foto50

SonjaGalileo wrote: ...BUT when I try to use the website, I get a 404 error...

How do u mean this?

Please Log in or Create an account to join the conversation.

4 months 1 week ago #3755 by SonjaGalileo

foto50 wrote:

SonjaGalileo wrote: ...BUT when I try to use the website, I get a 404 error...

How do u mean this?


When I enter information into my profile (1st life, 2ndlife, etc) within the viewer the information saves. But when I try to use jOpensim on the profile page, I enter the same information into the text fields. Once I click submit I get a 404 error page and the information is not saved.

I used a random character generator to test various amounts of characters to see if I was hitting a table field limit. I tried with the standard amount of 255 characters, clicked submit and I was returned to the profile page with a green success message. I again tested with some more amounts up to 2500 characters, each time I get a green success message and the random data is saved.

But if I try to enter just plain English information I get the 404. I even tried stripping out punctuation (commas, quotes) but still get the 404.

I'm not sure how else I can explain other than doing a video screen capture.

Please Log in or Create an account to join the conversation.

4 months 1 week ago #3758 by foto50
Hmm, understand now ... to admit a little strange for me ;)

But to be honest, I have no experience with IIS at all. Do u have SEF (Search Engine Friendly URLs) enabled in Joomla's global config? And if yes, would it work if turned off?

Please Log in or Create an account to join the conversation.

4 months 1 week ago #3759 by SonjaGalileo
In my attempt to get a good working install and in the process of consolidating all my servers onto one provider I scrapped IIS on the Opensim machine and now just running the "vanilla' DreamGrid with Apache.

Yes, joomla's SEF option was turned on. I turned it off, same results.

Please Log in or Create an account to join the conversation.

4 months 1 week ago #3760 by SonjaGalileo
I am SO SO SO sorry, all this time we've been going back and forth on the event issue and I NEVR thought to include the error message on the 404 page. (I'm getting a bit "slow" in my old age."
If difficulties persist, please contact the System Administrator of this site and report the error below.

1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 've been doing 3D modeling starting with Microsoft Flight Simulator 2002, so I kn' at line 4

Please Log in or Create an account to join the conversation.

4 months 1 week ago #3761 by SonjaGalileo
It looks like it is related to the use of ' marks in the text box. I stripped them all out and it saved successfully.

Please Log in or Create an account to join the conversation.

Time to create page: 0.107 seconds

Search

Donate jOpenSim

Please consider supporting our efforts.

Amount

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
BareBad… 997 997
Bohemas 996 998
BoraBor… 1002 999
Crystal… 1001 1000
DeepTho… 1005 998
FoToSan… 999 995
jCity 1001 997
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
LindaKe… 1000 997
LittleC… 996 997
MonteSc… 1001 1001
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
Tartola 997 998
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

jOpenSimWorld

Grid Status: Online
Total Regions: 23
Visitors (30 Days): 13
Total Residents: 454
Online Now: 0
Hypergriders online: 0