jOpenSimWorld

Grid Status: Online
Total Regions: 23
Visitors (30 Days): 15
Total Residents: 458
Online Now: 0
Hypergriders online: 0

Now jOpensim search does not work.

8 months 3 days ago #3762 by SonjaGalileo
Sorry for all the "double posts" But there is no edit post function that I can find.

The use of commas is ok.

Same with double quotes, "

But when you use a single quote as you do for contractions it fails. This is probably due to how MySQL uses them to delimit field contents in the database. so rather than being escaped and passed through it is seeing them as delimiter marks and the submission no longer meets the databases expectations on what is being sent.

I'm no database expert but since working with Opensim and Halcyon since 2016 I have seen such errors while helping a Dev develop a web interface to Halcyon.
The following user(s) said Thank You: foto50

Please Log in or Create an account to join the conversation.

8 months 3 days ago - 8 months 3 days ago #3763 by foto50
Oh well, good u found the issue more or less ... but it looks like u found a bug ;)

The mark should be escaped correct using Joomla's builtin query security. I'll check this out tomorrow and let u know

Greetz

Edit: the edit should be in the [Action] drop down below, but is/should be there only for a limited time

Please Log in or Create an account to join the conversation.

8 months 3 days ago #3764 by SonjaGalileo
I may not be good for a lot of things these days, but I am good at running into them nasty bugs, lol! B)

OH, by the way, I was able to create an event successfully on a Parcel I own and have set to a group!

WooooHoooo, progress!!!!! :woohoo:

Please Log in or Create an account to join the conversation.

8 months 3 days ago #3765 by SonjaGalileo

foto50 wrote:
Edit: the edit should be in the [Action] drop down below, but is/should be there only for a limited time


How limited? I don't see it at all.

Please Log in or Create an account to join the conversation.

8 months 3 days ago #3766 by foto500
Testing as regular user ;)

Please Log in or Create an account to join the conversation.

8 months 3 days ago #3767 by foto50
you're right, for some mystic reason, the feature was disabled again in kunena's backend ... now enabled again ... edit time 600 seconds ;)

Please Log in or Create an account to join the conversation.

8 months 3 days ago #3768 by SonjaGalileo
See, I told ya I was good at running into "them bugs", lol.

Please Log in or Create an account to join the conversation.

5 months 1 week ago #3790 by SonjaGalileo
I freed up a PC recently, so I decided to check in on the DreamGrid project. I noticed v5 was out so I decided to give it another whirl.

Looks like the single quote bug is still there. :P

I entered in my About Me stuff and got the 404 error. I stripped out the single quotes and it took.

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago #3791 by SonjaGalileo
I am running version 5.15. When I start DG and log into the grid I get:
06:46:18 - [XMLRPC-GROUPS-CONNECTOR]: Error when calling groups.getAgentActiveMembership for fd094c54-2b04-4c99-a889-b65615a5acc0 with params AgentID:fd094c54-2b04-4c99-a889-b65615a5acc0.  Response params are error:No access to groups!, message:No access to groups!, success:False, errorMessage:No access to groups!
06:46:18 - [XMLRPC-GROUPS-CONNECTOR]: Error when calling groups.getAgentGroupMemberships for fd094c54-2b04-4c99-a889-b65615a5acc0 with params AgentID:fd094c54-2b04-4c99-a889-b65615a5acc0.  Response params are error:No access to groups!, message:No access to groups!, success:False, errorMessage:No access to groups!

The read and write keys are correct in OpenSim.ini

When I click on an avatar and try to view the profile I get:
07:01:34 - [XMLRPC-GROUPS-CONNECTOR]: Error when calling groups.getAgentGroupMemberships for fd094c54-2b04-4c99-a889-b65615a5acc0 with params AgentID:fd094c54-2b04-4c99-a889-b65615a5acc0.  Response params are error:No access to groups!, message:No access to groups!, success:False, errorMessage:No access to groups!

And when I try to do a search inworld I get popups "No access to search!"

Please Log in or Create an account to join the conversation.

2 months 4 days ago #3802 by Ferdzee
You do not have to make INI files Read Only. They are already modified for jOpensim. If you wish, edit the INI files that are in the Proto folder in OutworldzFiles\Opensim\bin\config-include\Proto\Robust and in Joomla folder. and mark them read only if DreamGrid changes them in ways you do not like.

DreamGrid already makes all the mods to run jOpensim. If you report to me what mods you need I can add them after they are tested.

For DLL's, you add the DLL to the dlls.txt file and it will not overwrite them. This file is used to disable Joomla and other dlls after updates. It will make a .bak file when Joomla is Off, and rename it to .dll when it is on. You cannot just add DLLs to Opensim bin without them being loaded, as as you know now, this will crash Opensim if not set for them. And DLL's are often deleted by core so updates would be impossible.
The following user(s) said Thank You: foto50

Please Log in or Create an account to join the conversation.

Time to create page: 0.109 seconds

Search

Donate jOpenSim

Please consider supporting our efforts.

Amount

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
BareBad… 997 997
Bohemas 996 998
BoraBor… 1002 999
Crystal… 1001 1000
DeepTho… 1005 998
FoToSan… 999 995
jCity 1001 997
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
LindaKe… 1000 997
LittleC… 996 997
MonteSc… 1001 1001
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
Tartola 997 998
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

jOpenSimWorld

Grid Status: Online
Total Regions: 23
Visitors (30 Days): 15
Total Residents: 458
Online Now: 0
Hypergriders online: 0