Thoughts on opensim 0.9.2

3 months 1 week ago #3549 by andrewheritage
Although I realize that only the current release is officially supported, I did try running on the current OSGrid version ( 0.9.2.dev.81873a5 2020-11-27) and most jOpenSim seems to work all apart from the money system. On startup of a simulator I get the following error and it just won't start if the jOpensimMoney.dll file is in the bin folder:
[REGIONMODULES]: Loading Region's modules

Fatal error: System.MissingMethodException: Method not found: void OpenSim.Region.Framework.Scenes.EventManager.add_OnMakeRootAgent(System.Action`1<OpenSim.Region.Framework.Scenes.ScenePresence>)
  at OpenSim.ApplicationPlugins.RegionModulesController.RegionModulesControllerPlugin.AddRegionToModules (OpenSim.Region.Framework.Scenes.Scene scene) [0x000ed]: in <3f45fe89a8164fda8caee7163d61cc8c>:0  
  at OpenSim.OpenSimBase.CreateRegion (OpenSim.Framework.RegionInfo regionInfo, System.Boolean portadd_flag, System.Boolean do_post_init, OpenSim.Framework.IScene& mscene) [0x001bb] in<efdd0985d7bf45b08e27e01ba6a86b79>:0 
  at OpenSim.OpenSimBase.CreateRegion (OpenSim.Framework.RegionInfo regionInfo, System.Boolean portadd_flag, OpenSim.Framework.IScene& scene) [0x00001] in <efdd0985d7bf45b08e27e01ba6a86b79>:0 
  at OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise () [0x00146] in <4d5727c245444df6abc225fed4504c64>:0 
  at OpenSim.OpenSimBase.StartupSpecific () [0x0028e] in <efdd0985d7bf45b08e27e01ba6a86b79>:0 
  at OpenSim.OpenSim.StartupSpecific () [0x00107] in <efdd0985d7bf45b08e27e01ba6a86b79>:0 
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x000a1] in <bbda8f2958884a5ea12a25dc7515b484>:0

If there are any thoughts on what is wrong that would wonderful! (I suspect 0.9.2 isn't that far off becoming an official release!)

Please Log in to join the conversation.

3 months 1 week ago #3550 by foto50
Hi Andrew

The method OnMakeRootAgent is a basic method in OpenSimulator since ages. This having now as a "MissingMethodException" is surely a bit odd, but for me not really surprising as long as it is a dev version ;)

I spent many, many days for all the dll modules when version was about to change from 0.7.x to 0.8.x and just a few days before the first official 0.8.x release everything was completely different again and most had to be reverted to what it was before.

So this why I keep it now with "I'll look into it when it is released" ;)

Greetz
FoTo50

Please Log in to join the conversation.

3 months 6 days ago #3552 by andrewheritage
Thanks for the reply - I posted mostly in case you saw an obvious problem so sounds like not that. Totally understand about waiting until 'official' opens release. I run the OSGrid current release but they updated that about three times in quick succession so I totally understand how things change!

Please Log in to join the conversation.

Time to create page: 0.073 seconds

Search

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
Bay Sho… 997 1003
BoraBor… 1002 999
Canary … 997 999
Crystal… 1001 1000
DeepTho… 1005 998
FoToSan… 996 995
jCity 1001 997
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
LindaKe… 1000 997
MonteSc… 1001 1001
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

Donate jOpenSim

Please consider supporting our efforts.

Amount