jOpenSimWorld

Grid Status: Online
Total Regions: 24
Visitors (30 Days): 19
Total Residents: 447
Online Now: 0
Hypergriders online: 0
× Creating OpenSim accounts during Joomla! registration

Missing email field on registration

9 years 11 months ago #1199 by jmbolanos
When creating a new opens account, the email field is missing. the text is there but no entry field.

www.tardisnetwork.com/badwolf for the example.

Thanks in advance for your support

John

Please Log in or Create an account to join the conversation.

9 years 11 months ago #1200 by foto50
Hi John,

the link you used there for creating an opensim account is usually only used for already existing joomla accounts and should be only visible to registered users. Otherwise, jOpenSim will fail to refer the opensim account to a valid joomla account and will not be able to display account information correctly. (see more info on page 7 to 8 of the readme )

If you want new users directly to register their opensim account together with the joomla account you rather would prefer to use the plugin jOpenSimRegister . After enabling the plugin in your plugin manager and checking if the desired forms are enabled in the parameters of "System - jOpenSimRegister" the additional fields first name and last name should turn up in the regular joomla user registration form.

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

9 years 11 months ago #1201 by jmbolanos
Hi

I have followed that procedure (as I had before) - on the registration page I only have Required field

Name: *

Username: *

Password: *

Confirm Password: *

Email Address: *

Confirm email Address: *

Could it be my template?

Please Log in or Create an account to join the conversation.

9 years 11 months ago #1202 by foto50
Yes, some templates can mix up the plugin a little, specially if they dont stick to Joomla's standard definitions. It could help if you test by switching back shortly to a standard template and see if the fields would turn up then.

If they do, it is most probably the template. In that case, I ask you to give me further info about it so I can investigate it a little closer and see why it is like this. Maybe I find a solution for the next release of jOpenSimRegister.

If they still do not turn up, we'ld need to investigae a little closer, what setting is still missing ;)

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

9 years 7 months ago #1332 by annakarlafti
Hello FoTo50,

And thank you for the great plugins you have given us! :)

I am posting this today because I face the same problem as the friend above...
Reading your reply, I tried to test the plygin with the default Joomla templates but it still gave the same results...the email field was missing...

Do you have any ideas why this is happening?

Sincerely and with best regards,

Anna Karlafti

Please Log in or Create an account to join the conversation.

9 years 7 months ago #1333 by foto50
Hi annakarlafti,

and welcome to our forum :) I just checked and it seems jmbolanos solved it with a different template for the registering. Unfortunately I did not get any feedback after from him/her.

Does the text also show up with you, but not the input field? Or does both not turn up? Is there any url I could investigate?

Greetz
FoTo50

PS.: if the url should not be public yet, you also can send it to me via pm ;)

Please Log in or Create an account to join the conversation.

9 years 7 months ago #1334 by annakarlafti
Hello again!:)

And thank you for you very quick reply too!!!

It only misses the email field. The imput field. The text "Email:" is displayed properly...

I will send you the url in a pm. Very kind of you to offer your help this way! :):)

With best regards,

Anna Karlafti

Please Log in or Create an account to join the conversation.

9 years 7 months ago #1335 by jmbolanos
Hi all

Good to see this topic reignited. I haven't had much time to develop my opensim project but following the original post I had to use a simple template. I previously used a YooTheme template but ran into problems with the elements.

I just have a different theme show on the registration page.

John

Please Log in or Create an account to join the conversation.

9 years 7 months ago #1336 by foto50
Hi Anna

I investigated your site now a little and found following:

It seems you are mixed up a little by the different ways, how an OpenSim account can be created via jOpenSim:

The first link "Login / Register" on your website goes to "index.php?option=com_opensim&view=inworld&layout=default.create". This is for creating an OpenSim account for already existing Joomla users and should be visible for registered users only. Once a user is registered and logged in in Joomla, there is written the email just as text for the initial OpenSim account creating procedure regardless of the settings in jOpenSim (I admit this is a bit confusing).

After the OpenSim account is created, the page will then display the edit form with all fields enabled from jOpenSim settings.

If you want new users create a Joomla account AND an OpenSim account in one go, the plugin jOpenSimRegister is the one. It is installed with you and it looks as if it does have problems with this template. When you change the template e.g. to Beez5 and look to your "index.php?option=com_users&view=registration", you will see the Firstname and Lastname fields turning up between "User Registration" and "User Profile". But it does not with your desired template :(

During developing another commercial plugin lately, I have found some nice and interesting new functions in Joomla 2.5.x and will try them out soon with jOpenSimRegister in hope that this will solve this issue.

Also: I could see that you already have some existing OpenSim accounts, but no Joomla account for it. To let those users benefit from the features of jOpenSim, you need to create a Joomla account for them (or let them create it) and "connect" the Joomla account with the OpenSim one via jOpenSim User management with the "Joomla <--> OpenSim" button up right. Alternatively (e.g. if they are too many to do so manually) you can enable the "Inworld Account Identification" in jOpenSim settings to provide some inworld terminals, where existing can connect their OpenSim account right themselve in your grid.

I hope this could clear the registration procedure a bit :)

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

9 years 7 months ago #1337 by foto50
I have just seen that there is an update available for the template "Yoo_radiance" (see Extensions --> Template Manager --> Styles --> yoo_radiance - Default --> Edit) ... maybe this can solve the issue in your case. Please let me know!

Greetz
FoTo50

Please Log in or Create an account to join the conversation.

Time to create page: 0.175 seconds

Search

Donate jOpenSim

Please consider supporting our efforts.

Amount

Our Regions

Region: Loc X: Loc Y:
Agora 1000 998
BareBad… 995 996
Bay Sho… 997 1003
Bohemas 994 997
BoraBor… 1002 999
Crystal… 1001 1000
DeepTho… 1005 998
FoToSan… 996 995
jCity 1001 997
jOpenWe… 1000 999
JuniorT… 1002 1001
Kanadah… 1002 1000
LindaKe… 1000 997
LittleC… 994 996
MonteSc… 1001 1001
Naos 999 999
Pangaea 1005 1003
RiverSi… 999 1000
Sakani 999 998
Snambin 1001 998
Tartola 995 997
ViewerH… 1002 998
WaterWo… 1001 999
WilderK… 1000 1000

jOpenSimWorld

Grid Status: Online
Total Regions: 24
Visitors (30 Days): 19
Total Residents: 447
Online Now: 0
Hypergriders online: 0